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QA Introduction
Brings the power of automated standards enforcement to your projects to accelerate your
development process. Our highly configurable and extensible software ensures that your
applications remain high performing and consistent to make maintenance efficient and effective.
Using the Console means QA checking your changed objects becomes a quick and simple task.
When objects don't conform, clear reports pinpoint the issue and tell you how to address it. The
software also produces a Compliance Certificate so when it comes to a QA Review, the necessary
documentation is all to hand leaving you with more time to do actual development.
By taking a model/object view of your encyclopedia, you are presented with a tree view of all
encyclopedia models which can be expanded through object type nodes down to individual
objects. Checks can be run at the model level, object type level, aggregate set level, subset level,
against individual objects or user built lists of objects.

Model List
This pane provides the encyclopedia model listing and
allows the user to navigate to the desired object type or
types by expanding or contracting the nodes.
Depending upon the site's security preference, the model
list will contain either all models in the encyclopedia or
only those models the user is authorised for.
Should a model be added to or removed from the
encyclopedia during a session the Model List can be
refreshed using the File menu option or tool bar push
button.
Clicking on a model name will trigger an object fetch that,
when completed, causes the name to be displayed in bold.
The model is then ready for use and its tree can be
expanded. Models that are used often can be marked as
favourites by right clicking them and selecting
Add/Remove to Favourites from the Model menu.
Favourite models are indicated by a star next to the model
name and its tree will be automatically loaded when the
application Console is next opened.
The Model Filter field allows the user to reduce the model
list to those containing the desired value. Simply start
typing in this field to filter models.
Select an object by clicking it or use the SHIFT key and
click to select multiple objects.
Once objects are selected, choose from the toolbar menu
options, push buttons or right click menu to perform the
desired feature.
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Model Explore
This pane displays all objects contained within
the node selected in the Model List pane. For
example, if the model name is selected the
Model Explore pane will display every object in
the model. If the Online (Procedure Steps) node
is selected in the Model List pane the Model
Explore pane will display only online procedure
steps for the current model.
The Model Explore pane cannot display objects
from more than one model.
The Filter field allows the user to reduce the
object list to those containing the desired value,
simply start typing in this field to filter objects.
Select an object by clicking it or use the SHIFT
key and click to select multiple objects.
Once objects are selected, choose from the
toolbar menu options, push buttons or right click
menu to perform the desired feature.
The columns that are displayed for the objects
listed are user configurable from OPTIONS >
PREFERENCES > COLUMN PREFERENCES.
Additionally, the feature invoked by double
clicking on an object can be configured from
OPTIONS > PREFERENCES > GENERAL
OPTIONS.

Pick List
This pane displays objects the user has specifically
selected for inclusion.
The Pick List is populated by highlighting an object in
a pane or report output and selecting the Add to Pick
List option. Object types that cannot be added to the
Pick List are Supplied Functions, Users and User
Groups.
Once in the Pick List pane, objects can be removed
either by highlighting them and using the Remove
option or the Clear List option.
When working in the Pick List, highlighting objects is
only significant when removing objects from the Pick
List.
Pick List features will execute against every object
contained in the list where appropriate. Choose from
the toolbar menu options, push buttons or right click
menu to perform the desired feature.
Add to Pick List
Remove from Pick List
Clear List
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Locating Objects
Filter
To open this search, right click on a model or one of
its nodes in the Model List pane and choose Filter
Object(s).
The Find Options supports:
•

Object Name field. Enter the full name or partial
name of the object. More than one character
string may be entered.

•

AND/OR radio buttons. If more than one character
string has been entered in Object Name then this
field will determine how the strings are to be
handled. NOTE that AND/OR applies only to the
Object Name field.

•

Member Name/Domain. If this field is populated
then the character string entered is checked
against the Member Name for any Action Diagram,
and against the Domain type for any attribute
(entity, subtype or workset type). A partial match
is done so, for example, searching for TE would
give you objects with domain type DATE or TEXT
(or any other domain type containing TE).

•

Object ID. This is used to find a single object in
the model. An exact match, not a partial match, is
done.

Multiple filters may be applied simultaneously to
different nodes.
Filters applied to different nodes will not interact
unless one of the nodes is in the branch or branches
under the other. For example, a filter on Screens will
not interact with a filter on Batch Procedure Steps and
vice versa.
Criteria applied to a parent node will be ‘ANDed’ to any
criteria applied to its child nodes.
If an object isn't in the tree, schedule a tree extract
with the MODEL > CREATE EXTRACT TASK option.
Talk to your administrator about scheduling this to run
automatically.

Changed By Report
This option allows a user to nominate the
desired date range to return all objects
changed between those dates within the
current selected model. The report will include
all objects changed by any user.
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Task Pane
Tasks provide a way for some features to be submitted as a scheduled job. Similar to objects,
select a task to enable all features relevant to its type.
Supported features are:
•

Model Extract

•

Model QA Checks (Summary and Detail)

•

Object QA Checks (Summary and Detail)

Both Summary and Detail Reports can be submitted to run as scheduled jobs by selecting the
Run as Scheduled Task tick box on the Options window. If there are subsets or aggregate sets
included and it's really their contents that need checking make sure to select the Expand
Subsets/AggSets tick box. Specify the desired Task Info and click OK to submit.
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Task View
The Task View pane is used to indicate one or more criteria
that can be used to locate an existing task.
Expand nodes to select the desired filter values for each
property. Where no selections are made, no filter is applied.
For example, if no User is selected then tasks submitted by
all users will be displayed.
Tasks that meet the specified criteria are displayed as a list
in the Task List pane.

Task Status
Pending

Task is awaiting its scheduled processing start time.

Running

Task is currently being processed.

Completed Task processing is complete.
Held

Task is on hold awaiting release or cancellation.

Cancelled

Task processing is cancelled. Only a Pending or Held task can be cancelled.

Waiting

Task is waiting on another task.

Locked

Task is preparing for execution.

Failed

Task processing did not complete successfully.

Task List
Focus is automatically moved to this pane to display the output
of the requested Task View criteria.
The Task List pane offers the facility to monitor, hold, release or
cancel submitted tasks. As well as resubmit or view the outcome
of completed tasks.
Select a task by clicking it and choose from the toolbar menu
options, push buttons or right click menu to perform the desired
feature.
When a task is selected, its Detailed Report is automatically
displayed in the Task Details pane. This pane displays the details
of a submitted task such as the type of task, submitting User id,
status, queue, recurrence properties, when it was requested to
run, when it actually ran and whether it executed successfully.
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The columns that are displayed for the tasks listed are user
configurable from OPTIONS > PREFERENCES > COLUMN
PREFERENCES.

Task Features
Cancel
Task

This feature will cancel a task. Only a Pending or Held task can be cancelled.

Resubmit The resubmit feature offers the ability to resubmit a Cancelled, Completed,
Task
Failed or Held task for reprocessing.
Task
Results

The Results feature shows the output for an asynchronous task. The results will
differ based on the task type - for a download or upload task, the output will be
a checkout.trn or verify.trn file. Using the results feature for these types of task
will prompt for the folder location where those files are to be saved. For a QA
Check task, Pre-migrate Check task, adoption or a consistency check, the results
feature will display the report that has been output from the process.

Hold Task This feature will prevent the processing of a Pending task when its scheduled
execution time is reached (but not cancel it). A task placed in a Held status can
be released or cancelled.
Release
Task

This feature will restore the status of a Held task to Pending. If the scheduled
execution time has passed, the Task will execute immediately. Only the user
that submitted the Task can Release it.

Task Results
Focus is automatically moved to this pane to
display the results of the requested task.
All reports are interactive. Select an object
within the report by clicking it and choose
from the toolbar menu options, push buttons
or right click menu to perform the desired
feature.

Task Details
The Information Panel is at the bottom of the window. Clicking an item in the Task List presents
a summary of that report including what model it was run against and how many objects were
processed.
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Checking Objects
This feature can be
run against models,
individual objects or
multiple objects
simultaneously.

Summary or detailed reports are available that can highlight areas
where an object(s) does not conform to standards. These reports
can be generated online or submitted as a Scheduled Task to run at
a specified time. The progress and outcome of Scheduled Tasks can
be monitored in the Task List pane.
QA reports present the user with a set of QA Checks that can be run
against the highlighted object/s. Selecting to run a QA report opens
the last rule set used in the current model. A different rule set can
be selected in the top right drop down. Only those rule sets
associated to the current model will be available. Mandatory checks
cannot be deselected, they appear greyed out and are permanently
selected.

For those checks that are selected, a report is produced detailing
whether the object passed or failed. If the object failed a particular
check, further details are given.
The output of Scheduled Tasks are stored in the QA Tasks database
for later retrieval but the output of an online task is available as
soon as the task has executed in a Results tab.

Summary Report
A Summary report is a table of checked objects against selected checks showing if an object
passed, failed or is of a type not applicable to the check.
The Summary Report is invaluable for gaining a high level understanding of affected objects and
highlighting areas of concern. The Summary report option is chosen by deselecting the Detail
Report check box on the window.
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When a collection of objects changed for a unit of work are first uploaded, it provides an ideal
springboard to request Detailed Reports for those objects that fail one or more checks. Highlight
the failing objects (click on the Summary column to bring all failing objects to the top) and right
click.

Detail Report
After a Summary Report highlights objects that need attention, the Detail Report gives the greater
level of detail often required to pinpoint why an object has failed a check. For instance, if an
Action Block fails a statement related check, the report shows the statement in error - critical
information when there are several similar statements but only one is wrong!

The Detail Report also serves as a Compliance Certificate when work is ready to be submitted for
signoff. It records what checks were run and when, the objects they were run against and the
selected rule set so reviewers have everything they need to certify the work. Running the report
as a Scheduled Task stores the output against a unique Task ID which all reviewers have access
to.
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Model Level QA Check
This
feature is a
model
report.

The Model Level QA Check feature presents the user with a set of QA Checks
that can be run against an entire Model or all objects of the types selected in
the Query Criteria pane for the current Model. For instance if all Action Blocks
and Procedure Steps are to be checked the required Model is selected, the
Procedure Step and Action Block checkboxes checked, and then the Model
Level QA Check push button is pressed. If all object types are to be tested,
then select the "All Object Types" option.
Two methods of outputting the results are available:
1. Summary Table - this option takes all checked objects and indicates
whether they passed or failed the selected check(s) in a Pass/Fail matrix.
2. Detailed Report - this option takes all checked objects and produces a
more detailed report including the checks selected, those NOT selected and
the details of check failures.
This feature can be run either online or scheduled to run as an asynchronous
task, the latter being recommended for Model level checking. Their progress
and outcome can be monitored in the Task List pane.
Refer to the Technical Guide for details on the authority required to execute
this feature.
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Options and Preferences
There are a number of options and preferences that can be set in the Client. These options are
set for all instances of the Client installed on a workstation.
These settings are reached by selecting the OPTIONS > PREFERENCES menu option.

Tracking Licence Usage
An Audit Report displays usage information. Administrators can use this to see the licence details
and which users have logged on and when. It is available under the OPTIONS > PREFERENCES
> AUDIT REPORT menu option to those with the necessary authority.

CSEConfig
If the configuration information needs to be changed after installation for any reason this can be
done from the CSEConfig tab given the user has sufficient authority to do so.

Client Configuration
The Client’s configuration can be changed after installation, for instance if the Server is relocated
the Address/Port can be modified here so that the Client can connect to the new Server.
Additional Client configurations can also be added to enable a client to connect to more than one
Server.

Server Configuration
Admin users are able to change the Server’s configuration from the Server Configuration tab.
Settings that might be changed from here are the Cache location (Please note: this path is relative
to the Server), Enforcing Model Authority, updating the configured Encyclopedia database
password (used by the Server) if the password is changed on the database and applying a new
licence.
For most of these settings the Server must be stopped and restarted for the changes to take
affect.
For further information regarding the Server Configuration please refer to the Server Installation
section in the Technical Guide.

Server Trace Settings
Various trace settings can be set here to assist Support with any support issues. These settings
should only be changed with assistance from Support.

PreLoad Models
Models added to the list of pre-loaded models are loaded into memory when the Server is started.
This improves performance when these pre-loaded models are first accessed by the Clients.
Please stop and restart the Server for the Pre-Load setting to take effect.

Collect Diagnostics
Selecting the "Collect Diagnostics" option will retrieve log and environment information files from
the Server and Client to aid Support with any support issues.
The location of the .7z file containing all these logs will be displayed at the bottom of the panel.

Column Preferences
Select the optional columns to be visible in the Explore Model and Task List tabs. This allows the
user to see only the information that is relevant to their needs.

Install Update
Use these settings to determine when and how updates are applied to the Client.

Restore Options
Under the Window menu, there are a number of Restore menu options to reinitialise changed
settings to the default values and re-open closed panes.
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Restore Defaults:

Reinitialises changes made to settings within Options -> Preferences to
their original values.

Restore PickList:

Re-open the Pick List pane if it has been closed.

Restore TaskView:

Re-open the Task View pane if it has been closed.

Restore Explore
Model:

Re-open the Explore Model pane if it has been closed.

Restore Task List:

Re-open the Task List pane if it has been closed.

Restore Welcome:

Re-open the "What's New" welcome panels.
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Printing and Saving
When the Summary Report is in focus, to print or save the report highlight the required rows and
press the Print or Save push button. When a Detailed Report is in focus, printing or saving outputs
the entire report regardless of what is highlighted.
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Contact Us
If you need more information or assistance please visit our website at:
http://www.response-systems.com
We welcome your feedback and suggestions.
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